Modber Сообщество
профессионалов по 1С

Создание нового документа в 1С 8.2



Платформы: 1С:Предприятие 8.2
Конфигурации: Все конфигурации
2013-01-12
13516 

 

Рассмотрим программное создания документа на платформе 1С:Предприятие 8.2, в примере создается документ "Заказа клиента" в Управление Торговлей 11.

код:

&НаКлиенте
Процедура Документ(Команда)
  новыйДок = СоздатьЗаказ();
  ОткрытьЗначение(новыйДок);
КонецПроцедуры

&НаСервере Функция
  СоздатьНовыйДокумент()
  ДокЗаказ = Документы.ЗаказКлиента.СоздатьДокумент();
  ДокЗаказ.Дата = ТекущаяДата();
  ДокЗаказ.Организация = Справочники.Организации.НайтиПоНаименованию("ООО Легион");
  ДокЗаказ.Статус = Перечисления.СтатусыЗаказовКлиентов.КОтгрузке;
  ДокЗаказ.Приоритет = Перечисления.Приоритеты.Средний;
  ДокЗаказ.Валюта = Валюта;
  ДокЗаказ.Менеджер = ПараметрыСеанса.ТекущийПользователь;
  ДокЗаказ.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС;
  ДокЗаказ.ЦенаВключаетНДС = Истина;
  СуммаД =0;
  Для Каждого запись Из Объект.Корзина Цикл
   строка = ДокЗаказ.Товары.Добавить();
   строка.Номенклатура = запись.номенклатура;
   строка.ВидЦены = запись.ВидЦены;
   строка.СтавкаНДС = запись.номенклатура.СтавкаНДС;
   строка.ДатаОтгрузки = запись.ДатаОтгрузки;
   строка.Количество = запись.Количество;
   строка.КоличествоУпаковок = запись.КоличествоУпаковок;
   строка.Цена = запись.Цена;
   строка.Сумма = запись.Сумма;
   СуммаД = СуммаД+запись.Сумма;
  КонецЦикла;
  ДокЗаказ.СуммаДокумента = СуммаД;
  ДокЗаказ.Записать();
  Возврат ДокЗаказ.ссылка;
КонецФункции


Программно заполняем все поля документа, и передаем ссылку в метод глобального ОткрытьЗначение(), который откроет форму нового документа.




Бесплатная юридическая
консультация по телефону

8 (499) 350-80-26(Москва)
8 (812) 627-15-62(Спб)

звонок бесплатный

В центре внимания

Комментарии (0)