Modber Сообщество
профессионалов по 1С

Вспомогательные формы для ввода числа даты (для сенсорных экранов)



Платформы: 1С:Предприятие 8.3, 1С:Предприятие 8.2
Конфигурации: Все конфигурации
2014-04-01
1733 
konyavka
0  

В колонке "Количество" на событие "НачалоВыбора" пишем обработчик:

&НаКлиенте
Процедура ТоварыКоличествоУпаковокНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    
    ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
    Если ТекущиеДанные = Неопределено Тогда
        Возврат
    КонецЕсли;
    
    ТекКоличество = _ВвестиЗначение(ТекущиеДанные.КоличествоУпаковок);
    Если ТекКоличество <> 0 Тогда
        ТекущиеДанные.КоличествоУпаковок = ТекКоличество;
        
        ТоварыКоличествоУпаковокПриИзменении(ТекущиеДанные);
    КонецЕсли;

КонецПроцедуры

//Функция _ВвестиЗначение() обращается к общему модулю, где вызывается внешняя обработка:

&НаКлиенте
Функция _ВвестиЗначение(Значение)
    
    Возврат ВнешниеФункцииКлиент.ВводЧислаДаты(Значение, ЭтаФорма)
    
КонецФункции    

//общий модуль

Функция ВводЧислаДаты(Значение, ВладелецФормы) Экспорт
    
    Если ТипЗнч(Значение) = Тип("Дата") Тогда
        
        ИмяФормы = "ФормаКалендаря";
        
    Иначе //число
        
        ИмяФормы = "ФормаВводЧисла"; 
        
    КонецЕсли;    
        
    Параметры = Новый Структура("Значение", ?(ЗначениеЗаполнено(Значение), Значение, ""));
        
    ИмяОбработки = ВнешниеФункцииКлиентПовтИсп.ПодключитьОбработкуФормы("Ввод числа или даты");
    ФормаОбработки = ПолучитьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма." + ИмяФормы, Параметры, ВладелецФормы);
    ФормаОбработки.ОткрытьМодально();
    
    Возврат ФормаОбработки.ВыбранноеЗначение;
    
КонецФункции

 

 

 



Как установить отработку или отчет 1С


Скачивание доступно только зарегистрированным пользователям.
Зарегистрируйтесь или войдите под своим аккаунтом.


В центре внимания

Комментарии (0)