Modber Сообщество
профессионалов по 1С

Примеры работы в 1С 8



Платформы: 1С:Предприятие 8.3, 1С:Предприятие 8.2, 1С:Предприятие 8.1
Конфигурации: Другие конфигурации
2014-04-29
2366 
maxdzhavala
0  

Как составить запрос к табличной части документа?


Пример запроса: 

Построитель.Текст = "ВЫБРАТЬ
|    Товары.Ответственный,
|    Товары.Ссылка КАК Документ,
|    Товары.Номенклатура,
|    СУММА(Товары.Сумма) КАК Сумма
|ИЗ
|    Документ.ЧекККМ.Товары КАК Товары
|ГДЕ
|    Товары.Ссылка.Дата Между &ДатаНач и &ДатаКон
|СГРУППИРОВАТЬ ПО
|    Товары.Ссылка,
|    Товары.Ответственный,
|    Товары.Номенклатура"; 

 

Особенность подобного запроса полагает в том, что используя его вы можете обратится к табличной части под названием «Товары». Именно из-за этого к реквизитам документа «ЧекККМ» мы обращаемся с помощью свойства «Ссылка». Только в таком случае вам в итоге удастся получить строки табличной части документа. Если же свойство «Ссылка» указано не будет, скорее всего появится примерно такая ошибка: 

{(7, 5)}: Поле не найдено "Документ.ЧекККМ.Дата"

 

Где в 1С:Предприятие 8 можно увидеть размеры МЗП и МРП?

Для этого вам понадобится открыть пункты меню: 
Операции-> Регистры Сведений-> Регламентированные расчетные показатели.
 

Где редактировать журнал в 1С:Предприятие 8 для документа, который не входит ни в один журнал?

В том случае, если этот документ не входит ни в один журнал из системы 1С:Предприятие 8, то тогда журнал для данного документа можно генерировать с помощью системы, делается это автоматически. Собственно этот журнал и является формой списка данного документа. Подобную форму списка можно не только создать в Конфигураторе, но еще и настроить ее там. 
 

Как изменить панель функций в 1С:Предприятие 8?

Собственно сама панель функции и является обработкой, ее ни в коем случае нельзя менять! В Конфигураторе она обычно находится в дереве метаданнных панели «Конфигурация», ветка «Обработки» называется она «ПанельФункций».
 

Как объединить конфигурации в 1С8?

Вот представьте только, вам передали .cf-файл, в котором ранее была изменена конфигурация. Что же делать для того, чтобы внести изменения в нее? Во-первых вам придется зайти в Конфигуратор и сделать выгрузку данных: Администрирование — Выгрузить информационную базу… После этого следует указать путь, в которой вы собственно и планируете выгружать данные, затем нужно будет назвать файл, сделать это к примеру можно текущей датой: 28.04.2014. Далее откройте дерево конфигурации. Для этого нужно перейти по пути: Конфигурация — Открыть конфигурацию. После проведения выгрузки нужно будет открыть пункт меню Конфигурация — Сравнить, объединить с конфигурацией из файла… На следующем этапе выберите .cf-файл, после этого должно появится кно «Сравнение, объединение», нажмите на команду «Выполнить», а после этого ОК. Для сохранения этой конфигурации нажмите на клавишу F7. 
 

Как правильно удалить строки из ТаблицыЗначений в 1С8? 

Предположим, к примеру, что вам необходимо удалить все строки из таблицы значений, которые во второй своей колонке содержат букву "G"
Процедура УдалитьСтрокиТаблицы(Таб);
    Сч = 0;
    Пока Сч < Таб.Количество() Цикл
        Строка = Таб[Сч];
        Если Найти(Строка.Получить(1),"G") > 0 Тогда
            Таб.Удалить(Строка);
        Иначе // Благодаря этой переменной мы 
              // не пропускаем строки в таблице значений
            Сч = Сч + 1;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры

Как реализовать цикл с уменьшающимся счетчиком?
Первый вариант.
Зн1 = 100;
Зн2 = 1;
Сч=Зн1;
Пока Сч>=Зн2 Цикл
    Сч=Сч-1;
КонецЦикла;


 

Второй вариант.

Для Сч = -Зн1 По -Зн2 Цикл
    // Чтобы получить положительную величину,
    // если вдруг Сч станет положительным.
    СчЗн = Макс(Сч, -Сч);
КонецЦикла;

Где храниться список баз в 1С:Предприятие 8?
В Windows список баз данных хранится в:
1С:Предприятие 8.1 — %AppData%1C1Cv81ibases.v8i
1С:Предприятие 8.2 — %AppData%1C1CEStartibases.v8i


 

Где у регистра сведений изменить способ редактирования записи?

Сделать это можно в дереве метаданных. Для этого с помощью ПКМ следует нажать на нужном регистре сведений. После это пройдите по пути: "Свойства — Способ редактирования" и выберите на свой собственный вкус "В списке", "В диалоге" или "Обоими способами"!




Бесплатная юридическая
консультация по телефону

8 (499) 350-80-26(Москва)
8 (812) 627-15-62(Спб)

звонок бесплатный

В центре внимания

Комментарии (0)