Modber Сообщество
профессионалов по 1С

Поправить дату запуска и исполнения в заказе на производство без перепроведения (УПП)



Платформы: 1С:Предприятие 8.2
Конфигурации: 1С:Управление производственным предприятием
Версия: 1.3.80.1
2016-12-26
556 
volink
0  

Описание функционала:

В правах у пользователей стоит запрет на исправление проведенных документов. Данная обработка позволяет пользователям исправить даты запуска и исполнения в документе Заказ на производство без перепроведения. 
Возможность записи документа без перепроведения достигается с помощью команды ОбменДанными.Загрузка = Истина. Для тех кто использует заказы на производство в обменах нужно продумать последствия использования данного механизма.

Обработка простенькая.Вот какие процедуры я использовал:

 

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если ЗначениеЗаполнено(Документ) тогда
        док=документ.получитьобъект();
        ИзмененияЕсть=Ложь;
        Если не док.ДатаЗапуска=ДатаЗапуска тогда
            док.ДатаЗапуска=ДатаЗапуска;
            ИзмененияЕсть=Истина;
        КонецЕсли;
        Если не док.ДатаИсполнения=ДатаИсполнения тогда
            док.ДатаИсполнения=ДатаИсполнения;
            ИзмененияЕсть=Истина;
        КонецЕсли;
            Док.ОбменДанными.Загрузка = Истина;
        Если ИзмененияЕсть тогда
            Док.Записать();
            Сообщить(сокрлп(док)+" ЗАПИСАН");
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Процедура ДокументПриИзменении(Элемент)
    ДатаИсполнения=дата(1,1,1);
    ДатаЗапуска=дата(1,1,1);
    Если ЗначениеЗаполнено(Документ) тогда
        ДатаИсполнения=Документ.ДатаИсполнения;
        ДатаЗапуска=Документ.ДатаЗапуска;
    КонецЕсли;
КонецПроцедуры

Обработка будет полезна начинающим. Как пример использования возможности редактирования реквизитов документа без перепроведения. Только надо помнить что редактируемые реквизиты не должны учавствовать в движениях документа.


 



Как установить отработку или отчет 1С


Скачивание доступно только зарегистрированным пользователям.
Зарегистрируйтесь или войдите под своим аккаунтом.


Комментарии (0)