Modber Сообщество
профессионалов по 1С

Как программно заполнить отбор в "ГрупповаяОбработкаСправочниковИДокументов" ?

Как программно заполнить отбор в "ГрупповаяОбработкаСправочниковИДокументов" ?
  
Сообщений: 9

0
Доброе время суток , подскажите пожалуйста как программно заполнить отбор в обработке "ГрупповаяОбработкаСправочниковИДокументов". Вот что уже сделано: [code=1C] Процедура ПриОткрытии() ТипОбъекта = 1; МассивТипов = Новый Массив; МассивТипов.Добавить(Тип("Булево")); МассивТипов.Добавить(Тип("Null")); ОписаниеТипаБулево = Новый ОписаниеТипов(МассивТипов); мСформированныйРежим = Неопределено; Если ОграничениеНаСтрокиНеограниченнойДлины = 0 Тогда ОграничениеНаСтрокиНеограниченнойДлины = 999; КонецЕсли; МетаданныеОбъектов = Метаданные["Документы"]; ИмяТипаОбъекта = "Документ"; Заголовок = "Отбор по документам"; Для каждого Метаданное Из МетаданныеОбъектов Цикл Строка = ТабличноеПолеВидыОбъектов.Добавить(); ИмяМетаданного = Метаданное.Имя; Строка.ИмяТаблицы = ИмяМетаданного; Строка.ПредставлениеТаблицы = Метаданное.Представление(); КонецЦикла; ИнициализацияЗапроса(); // Вот тут не понятно как заполнить отбор инициализации запроса //Отбор = ПостроительЗапроса_Отбор.Отбор.Проведен; //Отбор.Значение = Ложь; //Отбор.Использование = Истина; КонецПроцедуры [/code] Помогите пожалуйста если сталкивались. Заранее благодарен.
Сообщений: 7

0
Добрый день. Смотря что именно Вы хотите отобрать.
В начало страницы 
|
Перейти на форум: