Modber Сообщество
профессионалов по 1С

хочу рассортировать по полу и дате

нужна помощь
  
Сообщений: 2

0
Здравствуйте, хорошо что есть такой форум где всегда окажут помощь! С трудом вас нашел.
Я только учусь,просьба тапками не кидаться smileМожет кому-то мой вопрос покажется лешгим но тем не менее:
У меня такое вот такое задание:
Сформировать список сотрудников мужчмн и женщин, родившихся в указанный интервалвремени + указать количество детей.

Ну никак не работает отбор по мужчинам, и сортировка по дате рождения. Просто выводится весь список сотрудникови все. Дальше еще не продвинулся.
Выглядит это вот так:

Код 1C:
  1. Процедура КнопкаВыполнитьНажатие(Кнопка)
  2.  
  3. ТабличныеДанные.Очистить();
  4. СпрФЗ=справочники.ФизическиеЛица;
  5. ВыборкаДР=Справочники.ФизическиеЛица.Выбрать(НачПериода,КонПериода);
  6.  
  7. если ЭлементыФормы.Мужчины.Значение=1 тогда
  8. отбор=новый структура;
  9. отбор.вставить("пол","муж");
  10. отбор.вставить("дети",2);
  11. ВыборкаСпрФизЛица = СПрфз.Выбрать(,,Отбор);
  12. Иначе
     
    ВыборкаСпрФизЛица=СПрфз.Выбрать();
  13.  
  14. КОнецЕсли;
     
    Пока ВыборкаСпрФизЛица.Следующий()=Истина цикл
  15.  
  16. объект=ВыборкаСпрФизЛица.ПолучитьОбъект();
  17. Нов_строка=табличныеДанные.Добавить();
  18. Нов_Строка.Фамилия=объект.Имя;
  19. Нов_Строка.ДатаРождения=объект.ДатаРождения;
  20. Нов_Строка.дети=объект.КоличествоДетей;
  21. Нов_строка.пол=объект.пол;
  22.  
  23. КонецЦикла;
     
     
    КонецПроцедуры
     
    Процедура ВыбПериодНажатие(Элемент)
  24. НастройкаПериода = Новый НастройкаПериода;
  25. НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
  26. НастройкаПериода.РедактироватьКакИнтервал = Истина;
  27. НастройкаПериода.РедактироватьКакПериод = Истина;
  28. НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
  29. Если НастройкаПериода.Редактировать() Тогда
    НачПериода = НастройкаПериода.ПолучитьДатуНачала();
  30. КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
  31. КонецЕсли;
    КонецПроцедуры
Редактировалось: 1 раз (Последний: 19 декабря 2012 в 13:45)
МедальГрамота
Сообщений: 541

+8
Код 1C:
  1. Пока ВыборкаСпрФизЛица.Следующий()=Истина цикл
Давно такого не видел))))

Сделайте выборку через запрос и в запросе укажите сортировку.
МедальГрамота
Сообщений: 134

+9
+1 делай запросом и не парьтеся
Сообщений: 2

0
Спасибо scratch
В начало страницы 
Перейти на форум: