Modber Сообщество
профессионалов по 1С

Сравнить остатки ТМЦ из УТ11 с БП2

Не могу выбрать базу и подключиться к ней в Упр.приложении из УТ11
  
Сообщений: 8

+1
В Обычном приложении написана обработка для сравнения остатков ТМЦ из УТ10 с БП2. Так выглядит процедура: Процедура ПриОткрытии() //Получаем список баз 8.2 Шел = Новый COMОбъект("WScript.Shell"); Путь = Шел.RegRead("HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\AppData"); Путь = Путь + "\1C\1CEStart\ibases.v8i"; Текст = Новый ТекстовыйДокумент; Попытка Текст.Прочитать(Путь, КодировкаТекста.UTF8); Исключение Сообщить("Ошибка открытия файла!"); КонецПопытки; ЭлементыФормы.СписокИБ82.СписокВыбора.Очистить(); Для СчБ = 1 По Текст.КоличествоСтрок() Цикл ОбработкаПрерыванияПользователя(); СтрокаФайла = Текст.ПолучитьСтроку(СчБ); СтрокаИБ = Текст.ПолучитьСтроку(СчБ+1); Если (Найти(СтрокаФайла,"[") = 1) И (Найти(СтрокаИБ,"Connect=") = 1) Тогда //новая база НазваниеИБ = Сред(СтрокаФайла,2,СтрДлина(СтрокаФайла)-2); КаталогИБ = СтрЗаменить(СтрокаИБ,"Connect=",""); КаталогИБ = СтрЗаменить(КаталогИБ,"Ref="," Ref="); ЭлементыФормы.СписокИБ82.СписокВыбора.Добавить(КаталогИБ,НазваниеИБ); КонецЕсли; КонецЦикла; ЭлементыФормы.СписокИБ82.СписокВыбора.СортироватьПоЗначению(); Пользователь = "Администратор"; //удалить //НачПериода = НачалоГода(ТекущаяДата());//удалить //КонПериода = "31.01.2008 23:59:59"; //удалить //КонПериода = КонецГода(ТекущаяДата()); //удалить ЕИСФВБП = Истина; //удалить БПВЕИСФ = Истина; //удалить ЕИСФБП = Истина; //удалить //НомерВСоответствиеСБП = Истина; //подумать и удалить НомерЧисло = Истина; //удалить КонецПроцедуры А как она будет выглядеть в УПРАВЛЯЕМОМ ПРИЛОЖЕНИИ! Подскажите.Необходимо выбрать из списка баз нужную и к ней подключиться. На картинке В поле выбора "Список ИБ" должен появиться список баз (которые высвечиваются при запуске 1С8,2).Подскажите,начинаю изучать УТ11....
Прикрепленные файлы:
1_8cb55.jpg | 150.82 Кб | Скачали: 642
МедальГрамота
Сообщений: 544

+9
>>из УТ10 а с какого УТ 10 вдруг станет на управляемых формах? Надо смотреть и делать под УТ 11.
Сообщений: 8

+1
[quote=Alexandr] >>из УТ10 а с какого УТ 10 вдруг станет на управляемых формах? Надо смотреть и делать под УТ 11. [/quote] Имела ввиду ,конечно (из Упр.приложения УТ11).Т.е есть для обычного приложения из УТ10.а надо переделать для управл.придложения из УТ11.
В начало страницы 
|
Перейти на форум: