Modber Сообщество
профессионалов по 1С

  
Сообщений: 2

0
Дело состоит вот в чем, нужно из модуля формы "Документа(2)" вызвать процедуру в модуле объекта "Документа(1)". Иными словами должно быть что-то наподобие этого. 1) "Документа(1)" модуль объекта. "Если Константы.expИспрользоватьСтатусыДоговоров = Истина Тогда ПодписанПриИзменении(); КонецЕсли;" 2) "Документа(2)" модуль формы. "Процедура ПодписанПриИзменении(Элемент)Экспорт //Текст процедуры КонецЕсли;" КонецПроцедуры Как только запускаю на выполнение выкидывает ошибка. "Процедура или функция с указанным именем не определена (ПодписанПриИзменении) <>ПодписанПриИзменении(); (Проверка: Сервер)". Однако значение Экспорт у процедуры имеется.
Сообщений: 17

0
Если процедура размещена в модуле формы, то для доступа к ней, нужно получить саму форму. В данном случае целесообразнее перенести процедуру в модуль менеджера, тогда ее вызов будет выглядеть следующим образом: [code=1C]Документы.Документ2.ПодписанПриИзменении();[/code]
Сообщений: 199

+5
[quote=Solovei3000] Дело состоит вот в чем, нужно из модуля формы "Документа(2)" вызвать процедуру в модуле объекта "Документа(1)". ... Как только запускаю на выполнение выкидывает ошибка. "Процедура или функция с указанным именем не определена (ПодписанПриИзменении) [/quote] Из моделя объекта нельзя вызывать процедуры модуля формы. Наоборот можно Как говорилось выше лучше данную процедуру перенести в другой модуль(объекта или менеджера).
В начало страницы 
|
Перейти на форум: