Modber Сообщество
профессионалов по 1С

Помогите с параметрами!

  
Сообщений: 1

0
Здраствуйте!
Нужно сделать запрос, чтобы отслеживать «Результаты заключения» со списка. В случае отсутствия, вызывать исключение, идентифицировать эксперта и область где нет заключения. Запрос сделать попробовал, но не знаю как задать нужные параметры.
Кнопка в Справочнике проектов, а данные в документе «Сводное заключение»

//Обработка на кнопку


&НаКлиенте
Процедура bpОбработчикВыбораРезультатаПроверкиИнтерактивногоУсловия(Команда)
ПроверкаЗаключенийЭкспертов();
КонецПроцедуры


//Текст запроса



&НаСервере
Процедура ПроверкаЗаключенийЭкспертов()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| expЗаключениеЭксперта.РезультатЗаключения
|ИЗ
| Документ.expЗаключениеЭксперта КАК expЗаключениеЭксперта
|ГДЕ
| expЗаключениеЭксперта.РезультатЗаключения = &РезультатЗаключения";
СсылкаНа = Документы.expЗаключениеЭксперта.ПолучитьСсылку().РезультатЗаключения;
Запрос.УстановитьПараметр("РезультатЗаключения", СсылкаНа);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Если Не ЗначениеЗаполнено(Выборка) Тогда
ВызватьИсключение "Эксперт:("+ Объект.Номер +")";
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Сообщений: 6

+1
Попробуйте сначала получить нужный документ по ссылке.
ВашДокумент.ПолучитьОбъект();

А потом уже из него получайте результат. ВашДокументОбъект.РезультатЗаключения
В начало страницы 
|
Перейти на форум: