Modber Сообщество
профессионалов по 1С

Перенос справочников и документов из Excel

  
Сообщений: 7

0
Приветствую вас, возникла проблема. Не понимаю, что не так. Платформа 8.2(клиент-сервер).
Пользуюсь обычной загрузкой ЗагрузкаДанныхИзТабличногоДокумента82.epf, в ответ получаю error.

Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика — 'ПередЗаписью': {Справочник.itilprofТипыАктивов.МодульОбъекта(9)}: Ошибка при вызове метода контекста (ПередЗаписьюВидаОбъекта): Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода ПередЗаписьюВидаОбъекта (). Объект не загружен.

Тоже самое получается, если я пользуюсь Универсальный обмен данными формата XML(2.1.5). Когда пользуюсь файловым вариантом, все работает.

Помогите. Спасите. Не знаю, что делать. Подскажите решение проблемы. Буду очень благодарен.
МедальГрамота
Сообщений: 199

+5
Добрый день! Вы пытаетесь перед объект значение на сервер, а необходимо передавать ссылку на объект.
Сообщений: 1

0
Столкнулся на днях с такой же пробемой в УТ3 редакция 3.0.4.3

Ошибку получаем при записи объектов (элемент справочника, новый документ) программно в обычном приложении в серверном варианте хранения БД.

Записываю примерно так:
Код 1C:
  1. Процедура КнопкаВыполнитьНажатие(Кнопка)
  2. Док = Документы.ЗаказКлиента.СоздатьДокумент();
  3. Док.Дата = ТекущаяДата();
  4. Док.Записать();
  5. КонецПроцедуры
Получаю ошибку примерно такую:
Спойлер
Решений найдено 2.

1. Если вам не критично снять конфу с поддержки то в свойствах модуля на который ругается отлажчик надо
выставить свойство(Клиент обычное приложение).
З.Ы.: <Совет от КЭПА>: Если у вас в ОМ нет такого свойства зайдите в отладчике Сервис-Параметры — установите вариант "Управляемое и Обычное приложение" и св-во появится.

2. Если снимать конфу с поддержки не позволяет религия, нужно процелуру записи переделать под управляемый вариант, примерно так:

Код 1C:
  1.  
  2. &НаКлиенте
  3. Процедура ВыполнитьКлиент(Команда)
  4.  
  5. ВыполнитьСервер();
  6. Ссылка = ВыполнитьСервер();
  7. ОповеститьОбИзменении(Ссылка);
  8.  
  9. КонецПроцедуры
     
    &
    НаСервере
  10. Функция ВыполнитьСервер();
  11.  
  12. Док = Документы.ЗаказКлиента.СоздатьДокумент();
  13. Док.Дата = ТекущаяДата();
  14. Док.Записать();
  15.  
  16. Возврат Док.Ссылка;
  17.  
  18. КонецФункции
В начало страницы 
|
Перейти на форум: