Modber Сообщество
профессионалов по 1С

  
Сообщений: 7

0
Приветствую вас, возникла проблема. Не понимаю, что не так. Платформа 8.2(клиент-сервер). Пользуюсь обычной загрузкой ЗагрузкаДанныхИзТабличногоДокумента82.epf, в ответ получаю error. [quote]Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика - 'ПередЗаписью': {Справочник.itilprofТипыАктивов.МодульОбъекта(9)}: Ошибка при вызове метода контекста (ПередЗаписьюВидаОбъекта): Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода ПередЗаписьюВидаОбъекта (). Объект не загружен.[/quote] Тоже самое получается, если я пользуюсь Универсальный обмен данными формата XML(2.1.5). Когда пользуюсь файловым вариантом, все работает. Помогите. Спасите. Не знаю, что делать. Подскажите решение проблемы. Буду очень благодарен.
Сообщений: 199

+5
Добрый день! Вы пытаетесь перед объект значение на сервер, а необходимо передавать ссылку на объект.
Сообщений: 1

0
Столкнулся на днях с такой же пробемой в УТ3 редакция 3.0.4.3 Ошибку получаем при записи объектов (элемент справочника, новый документ) программно в обычном приложении в серверном варианте хранения БД. Записываю примерно так: [CODE]Процедура КнопкаВыполнитьНажатие(Кнопка) Док = Документы.ЗаказКлиента.СоздатьДокумент(); Док.Дата = ТекущаяДата(); Док.Записать(); КонецПроцедуры [/CODE] Получаю ошибку примерно такую: [spoiler]{Форма.Форма.Форма(73)}: Ошибка при вызове метода контекста (Записать) Док.Записать(); по причине: Ошибка при выполнении обработчика - 'ПередЗаписью' по причине: {Документ.ЗаказКлиента.МодульОбъекта(517)}: Ошибка при вызове метода контекста (УдалитьНеиспользуемыеСтрокиСерий) Док.Записать(); по причине: Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода УдалитьНеиспользуемыеСтрокиСерий (). [/spoiler] Решений найдено 2. 1. Если вам не критично снять конфу с поддержки то в свойствах модуля на который ругается отлажчик надо выставить свойство(Клиент обычное приложение). З.Ы.: <Совет от КЭПА>: Если у вас в ОМ нет такого свойства зайдите в отладчике Сервис-Параметры - установите вариант "Управляемое и Обычное приложение" и св-во появится. 2. Если снимать конфу с поддержки не позволяет религия, нужно процелуру записи переделать под управляемый вариант, примерно так: [CODE] &НаКлиенте Процедура ВыполнитьКлиент(Команда) ВыполнитьСервер(); Ссылка = ВыполнитьСервер(); ОповеститьОбИзменении(Ссылка); КонецПроцедуры &НаСервере Функция ВыполнитьСервер(); Док = Документы.ЗаказКлиента.СоздатьДокумент(); Док.Дата = ТекущаяДата(); Док.Записать(); Возврат Док.Ссылка; КонецФункции [/CODE]
В начало страницы 
|
Перейти на форум: