Modber Сообщество
профессионалов по 1С

Можно ли выдать предупреждение пользователю вместо сообщения?

  
Сообщений: 1

0
Друзья! Мне нужно оповестить всех пользователей. Т.е. необходимо в любое время разослать всем сообщение. Обычно, отправляю каждому используя "СообщениеПользователю". А есть ли, функция отправки сразу всем пользователям отправлять предупреждение? Обычное предупреждение не работает.
Грамота
Сообщений: 63

0
На мой взгляд, с лучшее решение этой задачи предложил kojinandrej, а именно: 1. В модуле обычного приложения в процеду ПриНачалеРаботыСистемы добавляем текст Код 1C v 8.х Форма = Обработки.ОповещенияПользователя.ПолучитьФорму("Форма"); Форма.Открыть(); 2. Создаем ОбщийМодуль под названием "опМодуль" в модуле вставляем текст Код 1C v 8.х Функция ВывестиОповещение(ИмяОтчета); ИмяФайла = ПолучитьИмяВременногоФайла(); Отчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(ИмяОтчета); ДвоичныеДанные = Отчет.ХранилищеВнешнейОбработки.Получить(); ДвоичныеДанные.Записать(ИмяФайла); опФорма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла); опФорма.Открыть(); УдалитьФайлы(ИмяФайла); КонецФункции Процедура ПроверкаНовыхОповещений() Экспорт ОтборПользователей = Новый Структура("Пользователь"); ОтборПользователей.Пользователь = ПараметрыСеанса.ТекущийПользователь; Оповещения = РегистрыСведений.ОповещениеПользователей.Выбрать(ОтборПользователей); КолОп = 0; Пока Оповещения.Следующий() Цикл Если Оповещения.Просмотрено Тогда Продолжить; КонецЕсли; КолОп = КолОп + 1; КонецЦикла; Если (КолОп>0) Тогда ВывестиОповещение("Оповещения пользователя"); КонецЕсли; КонецПроцедуры Процедура ЗадатьИнтервал(Интервал) Экспорт ПодключитьОбработчикОжидания("ПроверкаНовыхОповещений",Интервал,5); КонецПроцедуры Процедура ОчиститьИнтервал() Экспорт ОтключитьОбработчикОжидания("ПроверкаНовыхОповещений"); КонецПроцедуры 3. Создаем регистр сведений "ОповещениеПользователей". Добавляем измерения: "Пользователь" Тип:"СправочникСсылка.Пользователи", "Дата" Тип:"Дата", "Владелец" Тип:"СправочникСсылка.Пользователи", Ресурсы: "Просмотрено" Тип: "Булево", "Оповещение" Тип: "Строка" 4. Добавляем в конфигурацию необходимые Обработки и формы - пользуемся. Принцип Работы: При запуске 1с справой стороны в трее открыто оповещение пользователей. Открываем обработку Оповестить, пишим текст сообщения и отметив получателей отправляем сообщение. Когда сообщение приходит получателю, то форма оповещени появляется с правой стороны. Что бы сообщение считалось прочитаным, его необходимо открыть двойным щелчком правой клавиши мыши и оно откроется в новом окне как показао на третем изображении. В дальнейшем эти сообщения можно будет просматривать во вкладке "Просмотреные"
Сообщений: 49

+2
В модуле "ПриНачалеРаботыСистемы" запустите таймер и проверяйте флаг на сообщение. Каждый пользователь будет ловить этот флаг и выводить сообщение. Только нужно флаг добавить ещё в справочник "Пользователи", чтобы определять, прочитал пользователь сообщение или нет.
Грамота
Сообщений: 156

+2
Какой у вас клиент толстый или тонкий? В тонком клиенте есть аналогичная функция работает через ПоказатьПредупреждение или ПоказатьОповещениеПользователя берите, что вам нравится. Если клиент толстый то там отдельная песня, но решить тоже можно, добавить ещё одну константу и пару строчек кода. Опишите подробнее вашу задачу с указанием версии программы.
В начало страницы 
|
Перейти на форум: