Modber Сообщество
профессионалов по 1С

работа с dbf-файлами

  
Сообщений: 1

0
Привет. Имеется файл dbf, его необходимо загрузить в 1с7.7. Каким образом это произвести? Причем когда я раскрываю файл в Exel, то приобретаю одну долгую строку, как соображаю, обязан иметься список данных, будто бы табличка. Пожалуйста помогите разобраться, заблаговременно благодарю.
Сообщений: 69

+2
У 1C есть типовые функции работы с DBF - там проблем быть не должно. А в Excel может открываться некорректно в том случае, если первый раз при открытии DBF был неверно указан тип файла и Excel запомнил его как "текстовый документ". Открываете по двойному клику? Попробуйте через "Открыть как..."
Сообщений: 49

+2
Прочесть ДБФ можно так: дбф = СоздатьОбъект("XBase"); дбф.КодоваяСтраница(1); Если ФС.СуществуетФайл(ПутьДБ)=0 Тогда Сообщить("Файл не найден! "+ПутьДБ); Возврат; Иначе ДБФ.ОткрытьФайл(ПутьДБ); Если ДБФ.Открыта() = 1 Тогда Сообщить("База открыта "+ПутьДБ); Иначе Сообщить("Не смогли открыть Базу! "+ПутьДБ); Возврат; КонецЕсли; КонецЕсли; дбф.Первая(); Пока 1 = 1 Цикл // читаем данные Если ДБФ.Следующая() = 0 Тогда Прервать; КонецЕсли; КонецЦикла; дбф.ЗакрытьФайл();
Грамота
Сообщений: 156

+2
Вам готовую процедуру надо? Их в интернете полным полно, если нужны какие-то конкретные задачи прописать в обработке, можете написать мне в личку, обговорим детали и цену.
Сообщений: 34

0
Если у вас есть навыки работы программиста 1С, то вы без особых проблем очень быстро решите эту проблему руководствуясь инструкциями, которые предоставляет программа при работе с xBase, и которые хорошо описаны в литературе по 1С и в синтаксис-помощнике. Если таковых навыков у вас нет, то попросите фирму, которая сопровождает вашу 1С, помочь вам или же воспользуйтесь предложениями разработчиков на сайте.
Редактировалось: 1 раз (Последний: 15 сентября 2014 в 11:26)
Сообщений: 1

0
Обмен в формате DBF не представляет трудностей, к тому же, в сети полно информации о работе с этим форматом в 1С. Например, https://pro1c8.ru/obmen-dbf/
В начало страницы 
|
Перейти на форум: