Modber Сообщество
профессионалов по 1С

Модуль числа

  
Сообщений: 6

0
Подскажите, какую функцию надо использовать для создания модуля числа в 1с?
МедальГрамота
Сообщений: 541

+8
Математического модуля? или какого?
Сообщений: 3

0
Если я всё правильно понял, тебе нужен модуль числа: Модулем неотрицательного действительного числа a называют само это число:

|а| = а

Модулем отрицательного действительного числа х называют противоположное число:

|а| = — а

Простейшая функция: возвращает модуль числа:

Функция МодульЧисла(а)
Если а>0 Тогда
Возврат а;
Иначе
Возврат -а;
КонецЕсли;
КонецФункции
Редактировалось: 1 раз (Последний: 19 августа 2014 в 19:48)
Сообщений: 9

0
Попробуй эту:

Функция МодульЧисла(Число)
Попытка
Корень=sqrt(Число);
Возврат Число;
Исключение
Возврат -Число;
КонецПопытки;
КонецФункции;
Сообщений: 69

+1
Самый простой вариант:
Код 1C:
  1. МодульА = ?(А >= 0, А, -А);
В начало страницы 
|
Перейти на форум: