Modber Сообщество
профессионалов по 1С

Ошибка при выполнении обработчика - 'ОбработкаПроведения'

  
Сообщений: 1

0
Всем привет! При попытке проведения документа "Движение топлива" вылезает ошибка
Ошибка при выполнении обработчика — 'ОбработкаПроведения' {Документ.СписаниеНефтепродуктов1(49)}: Значение не является значением объектного типа (Пустая)
Если НЕ Стр.ДокументОприходования.Пустая() И (Стр.Количество > 0) Тогда

Текст процедуры выглядит так:

ПроверитьЗаполнение(Отказ);

Остаток = РассчитатьОстаток();

Таблица = Новый ТаблицаЗначений;
Таблица.Колонки.Добавить("Контрагент");
Таблица.Колонки.Добавить("ВидТоплива");
Таблица.Колонки.Добавить("Количество");
Таблица.Колонки.Добавить("ДокументОприходования");
Таблица.Колонки.Добавить("Дата");


Остатки = РегистрыНакопления.Партии;
Фильтр = Новый Структура;
Фильтр.Вставить("ВидТоплива",ВидТоплива);
Фильтр.Вставить("Контрагент", Контрагент);
ТабОстатков = Остатки.Остатки(Дата,Фильтр);
ТабОстатков.Колонки.Добавить("Дата");
Если ТабОстатков.Количество() <> 0 Тогда
Для Каждого Стр Из ТабОстатков Цикл
Если НЕ Стр.ДокументОприходования.Пустая() И Стр.Количество > 0 Тогда
Стр.Дата = Стр.ДокументОприходования.Дата;
НоваяСтрока = Таблица.Добавить();
НоваяСтрока.Контрагент = Контрагент;
НоваяСтрока.ВидТоплива = ВидТоплива;
НоваяСтрока.Количество = Стр.Количество;
НоваяСтрока.Дата = Стр.Дата;
НоваяСтрока.ДокументОприходования = Стр.ДокументОприходования;
КонецЕсли;
КонецЦикла;
КонецЕсли;
Таблица.Сортировать("Дата");

Когда ставлю точку останова, то в строке
Если НЕ Стр.ДокументОприходования.Пустая() И (Стр.Количество > 0) Тогда

Стр.ДокументОприходования.Пустая() = Ложь
Стр.Количество = 0.

Значит, дело всё же в Стр.Количество? Т.к. условие 0>0 не выполняется, поэтому он не хочет выполняться? Или в чём дело? Подскажите, пожалуйста.
Сообщений: 69

+1
Скорее всего в движениях регистра не заполнен реквизит "ДокументОприходования" и имеен значение NULL или Неопределено. Предлагаю заменить код на такой:
Код 1C:
  1.  
  2. ...
  3. Если ЗначениеЗаполнено(Стр.ДокументОприходования) И (Стр.Количество > 0) Тогда
    ...
  4.  
В начало страницы 
|
Перейти на форум: