Modber Сообщество
профессионалов по 1С

  
Сообщений: 41

+2
Управляемая форма. Создала в форме реквизит ПредварительныеДанные и ему присвоила тип Таблица значений, создала на форме таблицу ПредварительныеДанные и путь указала на уже созданный реквизит. Получила в процессе выполнения разных операций Таблицу значений с данными ТЗнач, но данные, которые в этой таблице мне нужно загрузить в ПредварительныеДанные, которые непонятно почему, имеют тип ДанныеФормыКоллекция, а должно быть Таблица Значений. Выполняю на сервере следующее: ПредварительныеДанные.Загрузить(ТЗнач); Но на форме в таблице в итоге отображается лишь из ТЗнач первая колонка. Как все колонки из ТЗнач можно вывести?
Сообщений: 50

+1
из ссылки в (5) &НаСервере Процедура ЗаполнитьТабЧастьНаФорме() // Реквизит формы "ДанныеТаблицы" создан средствами интерфейса конфигуратора(можно и программно), программно создадим колонки // Элемент формы "ДанныеТаблицыНаФорме" создан средствами интерфейса конфигуратора(можно и программно), программно создадим колонки // СодержимоеТаблицы - таблица значений // создаем реквизиты для РЕКВИЗИТА ФОРМЫ "ДанныеТаблицы" (тип Таблица Значений) МассивДобавляемыхРеквизитов = Новый Массив; Для Каждого Колонка Из СодержимоеТаблицы.Колонки Цикл РеквизитФормы = Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "ДанныеТаблицы", Колонка.Имя); МассивДобавляемыхРеквизитов.Добавить(РеквизитФормы); КонецЦикла; // пакетное создание и удаление колонок в РЕКВИЗИТЕ ФОРМЫ "ДанныеТаблицы" (тип Таблица Значений) ИзменитьРеквизиты(МассивДобавляемыхРеквизитов); // создаем элементы Для Каждого Колонка Из СодержимоеТаблицы.Колонки Цикл Элемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), Элементы.ДанныеТаблицыНаФорме); Элемент.Вид = ВидПоляФормы.ПолеВвода; Элемент.ПутьКДанным = "ДанныеТаблицы." + Колонка.Имя; КонецЦикла; ЭтаФорма.ДанныеТаблицы.Загрузить(СодержимоеТаблицы); КонецПроцедуры
В начало страницы 
|
Перейти на форум: