Modber Сообщество
профессионалов по 1С

8.2 Нельзя изменять поле, содержащее объект данных формы

  
Сообщений: 41

+2
&НаСервере
Процедура выборка(объект)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Работы.Исполнитель,
| СУММА(Работы.Сумма) КАК Сумма
|ИЗ
| РегистрНакопления.Работы КАК Работы
|
|СГРУППИРОВАТЬ ПО
| Работы.Исполнитель";

Результат = Запрос.Выполнить();
//тз=Результат.Выгрузить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
новаястрока=Объект.начисления.Добавить();
новаястрока.исполнитель=ВыборкаДетальныеЗаписи.исполнитель;
новаястрока.СУММА=ВыборкаДетальныеЗаписи.СУММА;
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
выборка(объект);
КонецПроцедуры

выдает ошибку:
{Документ.РаботыПоИсполнителям.Форма.ФормаДокумента.Форма(26)}: Ошибка при установке значения атрибута контекста (Объект)
выборка(объект);
по причине:
изменять нельзя поле, которое содержит объект данных формы
Сообщений: 50

0
не передавай ничего — у тебя и так вызов контекстный
В начало страницы 
|
Перейти на форум: