Modber Сообщество
профессионалов по 1С

  
Сообщений: 41

+2
Народ, как можно написать внешнюю обработку заполнения для табличной доли документа?? Что нужно в модуле писать? Постоянно выдает: метод "ИНИЦИАЛИЗИРОВАТЬ" не найден!
Сообщений: 50

+1
я делал примерно так - создал с доком нужного типа реквизит "Док" и сделал автоматически форму, а на кнопку повесил "выполнить" Процедура КнопкаВыполнитьНажатие(Кнопка) Инициализировать(Док.ПолучитьОбъект(), "Товары", ""); КонецПроцедуры
Сообщений: 2

0
Судя по Инициализировать - восьмерка... Если семерка - вопрос: в открытом документе или в закрытом?
Сообщений: 7

0
1. Создать в конфигураторе файл-новый-внешняя обработка. 2. Добавить новый реквизит: имя-СсылкаНаОбъект, тип-ДокументСсылка.ИмяДокументаКакВКонфигураторе. 3. Добавить новую форму. В форме на кнопку Выполнить разместить в действие процедуру: Процедура КнопкаВыполнитьНажатие(Кнопка) Инициализировать(СсылкаНаОбъект,"ИмяТабличнойЧасти",); КонецПроцедуры 4. Открыть модуль объекта обработки, в нем разместить переменную: Перем ИмяТабличнойЧасти; и функцию, которая будет содержать алгоритм обработки строк табличной части документа: Функция Инициализировать(СсылкаНаОбъект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт ИмяТабличнойЧасти = " ИмяТабличнойЧастиДокументаКакВКонфигураторе"; Запрос = Новый Запрос; Запрос.Текст = "Выбрать * |ИЗ | Документ." + СсылкаНаОбъект.Метаданные().Имя + "." + ИмяТабличнойЧасти + " Как Табл |Где | Табл.Ссылка = &Ссылка |"; Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект.Ссылка); ТЗ = Запрос.Выполнить().Выгрузить(); СсылкаНаОбъект. ИмяТабличнойЧастиДокументаКакВКонфигураторе.Очистить(); Для каждого Стр ИЗ ТЗ Цикл // ВАШ Алгоритм обработки строки ... ... // НоваяСтрока=СсылкаНаОбъект[ИмяТабличнойЧасти].Добавить(); ЗаполнитьЗначенияСвойств(НоваяСтрока,Стр); КонецЦикла; Возврат СсылкаНаОбъект; КонецФункции 5. Сохранить файл обработки. 6. Зайти в программу в режиме 1С:Предприятие. 7. В меню Сервис-Дополнительные отчеты и обработки- Дополнительные внешние обработки табличных частей. Добавить новую обработку, в ней выбрать ваш файл внешней обработки. В табличной части добавить нужный тип документа, указать название нужной табличной части документа и придумать название для кнопки, по которой ваша обработка будет вызываться. 8. Заходите в любой документ нужного типа, открываете нужную табличную часть. Над табличной частью появляется кнопка Заполнить, а в ее подменю будет расположена ваша обработка.
В начало страницы 
|
Перейти на форум: